Discord will not update

Good day,

Yesterday I denied a request by Discord regarding making a change whether it was an update to registry or otherwise, I promptly denied the change as it looked unnecessary. Now, up a new day, Discord simply tries to update and fails in a loop.

I’ve attempted reinstalling Discord several times, as well as, removing any denials within Comodo associated with Discord to no avail.
Also:
Running reinstall as admin, disabling Comodo completely and trying to update Discord upon reinstall.

I have Avast working beside Comodo, which I’ve been using for several years with no issues. I have not tried disabling Avast as it is tricky to do and don’t believe Avast is the culprit here.

Any thoughts would be greatly appreciated. I have not reinstalled Comodo upon fear of losing all learned associations, however, using this as a last resort.

Thank you for any feedback.

I was able to find the fix for this by going into Comodo Settings>HIPS Rules>Double-clicking on Discord and setting the entire directory to Allow. This finally worked. Hope this helps somebody seven years from now.

Keywords:
Discord
Comodo Firewall
Update Loop
Fail , Failure

DiscordFailUpdateComodo.JPG