Obselete dependency of the Comodo antivirus for linux

I tried to install the comodo antivirus for Ubuntu (Lubuntu 20.04) using

$ sudo dpkg -i cav-linux_x64.deb

and got the following message:

dpkg: error processing archive libssl0.9.8_0.9.8o-7ubuntu3. (--install):
unable to open '/lib/x86_64-linux-gnu/libcrypto.so.0.9.8.dpkg-new': No such file or directory
Errors were encountered while processing:

So, it depends on libssl0.9.8; this version of libssl is obselete, and does not exist later then Ubuntu 04.04, released 6 years ago, and obselete itself.

Do you know any way to fix it? Does Comodo team work on a new version? (If they are not planning to fix such things, the distribution such product should be stopped...)


Well, this forum seems to be obselete. Why do not they shut it down?
Links to relevant thread on the new Comodo forum:
libssl dependency issue
(49studebaker refers there to this guide, which seems to best cope with the libssl incpmpactibility error)
Later, you will find a driver problem. Look at this thread and this message. I did not try those fixes; proceed at your own risk.

Added a sceenshot of my support ticket. They say:

We apologize for the inconvenience and you please drop your issue related to Comodo Antivirus for Linux at the below link as it reaches our developers and moderators directly and they will help you further.

But this forum is full of questions about future update/shutdown, but no official response.

(TL;DR: Just do not rely on this obselete product)

Thanks buddy.

It seems that Linux support has been terminated a while back. I also had trouble setting-up libssl0.9.8 on Ubuntu 20.04.

you Don’t Need Any Anti-Virus in your LinuxMint System, anyway.

    • this is Not Windows, where there is an large hole, that needs to be filled by some A/V suite.